Release notes 3.3.2#


EclecticIQ Intelligence Center

Release version


Release date

May 2024

Time to upgrade

~40 minutes to upgrade an instance with 2.67 million entities, 1.85 million observables.

  • From the previous release

  • Using the installation script

  • For an instance running on one machine

Time to migrate

For an instance with 2.67 million entities, 1.85 million observables:

  • PostgreSQL migration: 13m30s

  • Elasticsearch migration: 18m40s

Important: Upgrade operating system#


EclecticIQ Intelligence Center 3.0.0 and newer requires one of these supported operating systems:

  • Red Hat Enterprise Linux 8

  • Rocky Linux 8

You must upgrade to one of the supported operating systems before installing EclecticIQ Intelligence Center 3.0 or newer.


Important: eclecticiq-extension-commons package is deprecated#


Only affects users who develop or customize EclecticIQ Intelligence Center extensions.

eclecticiq-extension-commons is deprecated in release 3.3, and will be removed in release 3.4.

If you have written your own extension, or modified an existing extension, that extension may contain references to the eclecticiq-extension-commons package.

In particular, if your extension:

  • depends on eclecticiq-extension-commons

  • imports from extension.common

You must remove or change those references in your extension before upgrading to the upcoming release 3.4. A migration guide will be provided.

Custom extensions will continue to work without modification in release 3.3.


  • Update KeyLines.js package

    The platform depends on a KeyLines license which was set to expire on 30 July 2024.

    This release extends that license and upgrades the KeyLines package from 5.10.3 to 7.4.1.

    Users who do not upgrade their platform instances to the following versions will have parts of the platform stop working after 30 July 2024:

    • 2.14.2

    • 3.0.4

    • 3.1.3

    • 3.2.2

    • 3.3.2

  • Retention Policy impact calculation

    Fixes a bug that caused the Retention Policy impact calculation to sometimes erroneously return 0.

Public API compatibility#

From EclecticIQ Intelligence Center 2.12.0 onward, the public API is packaged together with EclecticIQ Intelligence Center.

The following reference table lists the versions of the public API package and EclecticIQ Intelligence Center versions they are compatible with:

Intelligence Center version(s)

Public API package version(s)

Public API version

2.11 - 2.12






2.14.0 and newer

Now follows EclecticIQ Intelligence Center versioning scheme.

E.g., EclecticIQ Intelligence Center 2.14 is now compatible with eclecticiq-extension-api==2.14.*


3.0.0 and newer

EclecticIQ Intelligence Center 3.0 and newer uses Public API v2.

Follows EclecticIQ Intelligence Center versioning scheme.

E.g., EclecticIQ Intelligence Center 3.0.2 is compatible with eclecticiq-extension-api==3.0.*, EclecticIQ Intelligence Center 3.1.0 is compatible with eclecticiq-extension-api==3.1.*, etc.



For more information about setting up repositories, refer to the installation documentation for your target operating system.

EclecticIQ Intelligence Center and dependencies for Rocky Linux and RHEL

  • Platform packages:

  • Platform dependencies:


    The Intelligence Center dependencies URL for versions 2.9 and later is It contains packages that are incompatible with versions 2.8 and earlier.

EclecticIQ Intelligence Center extensions

  • Platform extensions:


The diagram below describes upgrade paths for EcelcticIQ Intelligence Center. See the following for upgrade instructions:

In order to upgrade to EclecticIQ Intelligence Center 3.0, you must:

  • Be running one of the supported operating systems.

    See Important: Upgrade operating system.

  • Upgrade from EclecticIQ Intelligence Center 2.14.

    If you are running an older version of EclecticIQ Intelligence Center, you must upgrade to 2.14 before attempting to upgrade to EclecticIQ Intelligence Center 3.0.

    See Install Configure Upgrade.

Upgrade diagram

Upgrade diagram#